diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 0717529fcdd1c78974639c470735eabd688e52fa..c80bc2eb6a7e625fcdd6305ab6b64b736b35df23 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -41,7 +41,6 @@ (define-public cmake
     (build-system gnu-build-system)
     (arguments
      '(#:test-target "test"
-       #:patch-flags '("-p0")
        #:phases (alist-replace
                  'configure
                  (lambda* (#:key outputs #:allow-other-keys)
diff --git a/gnu/packages/patches/cmake-fix-tests.patch b/gnu/packages/patches/cmake-fix-tests.patch
index ae28ca336bedc10c5bc503e411801d27399accf5..5327f3749a151b82be4997dfc45f0ed388a35b3e 100644
--- a/gnu/packages/patches/cmake-fix-tests.patch
+++ b/gnu/packages/patches/cmake-fix-tests.patch
@@ -1,5 +1,5 @@
---- Tests/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
-+++ Tests/CMakeLists.txt	2013-03-20 22:58:02.000000000 +0100
+--- a/Tests/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ b/Tests/CMakeLists.txt	2013-03-20 22:58:02.000000000 +0100
 @@ -1706,16 +1706,17 @@
      PASS_REGULAR_EXPRESSION "Could not find executable"
      FAIL_REGULAR_EXPRESSION "SegFault")
@@ -28,8 +28,8 @@
  
    configure_file(
      "${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
---- Utilities/cmcurl/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
-+++ Utilities/cmcurl/CMakeLists.txt	2013-03-20 23:08:41.000000000 +0100
+--- a/Utilities/cmcurl/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ b/Utilities/cmcurl/CMakeLists.txt	2013-03-20 23:08:41.000000000 +0100
 @@ -729,8 +729,9 @@
  ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
  TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})