From 6eac909b459301912becb854c112532ee3fd7cc3 Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Sun, 13 Oct 2013 17:00:18 +0200
Subject: [PATCH] gnu: cmake: Update patch to work with new system.

* gnu/packages/patches/cmake-fix-tests.patch: Update to work with -p1.
* gnu/packages/cmake.scm (cmake): Drop patch flag -p0.
---
 gnu/packages/cmake.scm                     | 1 -
 gnu/packages/patches/cmake-fix-tests.patch | 8 ++++----
 2 files changed, 4 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 0717529fcdd..c80bc2eb6a7 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -41,7 +41,6 @@ (define-public cmake
     (build-system gnu-build-system)
     (arguments
      '(#:test-target "test"
-       #:patch-flags '("-p0")
        #:phases (alist-replace
                  'configure
                  (lambda* (#:key outputs #:allow-other-keys)
diff --git a/gnu/packages/patches/cmake-fix-tests.patch b/gnu/packages/patches/cmake-fix-tests.patch
index ae28ca336be..5327f3749a1 100644
--- a/gnu/packages/patches/cmake-fix-tests.patch
+++ b/gnu/packages/patches/cmake-fix-tests.patch
@@ -1,5 +1,5 @@
---- Tests/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
-+++ Tests/CMakeLists.txt	2013-03-20 22:58:02.000000000 +0100
+--- a/Tests/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ b/Tests/CMakeLists.txt	2013-03-20 22:58:02.000000000 +0100
 @@ -1706,16 +1706,17 @@
      PASS_REGULAR_EXPRESSION "Could not find executable"
      FAIL_REGULAR_EXPRESSION "SegFault")
@@ -28,8 +28,8 @@
  
    configure_file(
      "${CMake_SOURCE_DIR}/Tests/CTestTestConfigFileInBuildDir/test1.cmake.in"
---- Utilities/cmcurl/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
-+++ Utilities/cmcurl/CMakeLists.txt	2013-03-20 23:08:41.000000000 +0100
+--- a/Utilities/cmcurl/CMakeLists.txt	2013-03-20 22:57:13.000000000 +0100
++++ b/Utilities/cmcurl/CMakeLists.txt	2013-03-20 23:08:41.000000000 +0100
 @@ -729,8 +729,9 @@
  ADD_EXECUTABLE(LIBCURL Testing/curltest.c)
  TARGET_LINK_LIBRARIES(LIBCURL cmcurl ${CMAKE_DL_LIBS})
-- 
GitLab