From 6ee48091a459f0fa48debe63d78cc1202d7fa95e Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Tue, 2 Apr 2019 15:08:22 +0200
Subject: [PATCH] gnu: Add python-louvain.

* gnu/packages/graph.scm (python-louvain): New variable.
---
 gnu/packages/graph.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 9dca2be98ed..7ed35f1f29e 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -245,6 +245,40 @@ (define-public python-plotly
 (define-public python2-plotly
   (package-with-python2 python-plotly))
 
+(define-public python-louvain
+  (package
+    (name "python-louvain")
+    (version "0.6.1")
+    ;; The tarball on Pypi does not include the tests.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/vtraag/louvain-igraph.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0w31537sifkf65sck1iaip5i6d8g64pa3wdwad83d6p9jwkck57k"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-ddt" ,python-ddt)
+       ("python-igraph" ,python-igraph)))
+    (inputs
+     `(("igraph" ,igraph)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/vtraag/louvain-igraph")
+    (synopsis "Algorithm for methods of community detection in large networks")
+    (description
+     "This package provides an implementation of the Louvain algorithm for use
+with igraph.  Louvain is a general algorithm for methods of community
+detection in large networks.
+
+This package has been superseded by the @code{leidenalg} package and should
+not be used for new projects.")
+    (license license:gpl3+)))
+
 (define-public faiss
   (package
     (name "faiss")
-- 
GitLab