diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index b836447668e4877c42af94257454fa940527426b..bcaccb452c8c1354f1cb400c34a3d46398c3b789 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1147,6 +1147,7 @@ (define-public femtolisp
          #:test-target "test"
          #:phases
          (modify-phases %standard-phases
+           (delete 'bootstrap)
            (delete 'configure) ; No configure script
            (replace 'install ; Makefile has no 'install phase
             (lambda* (#:key outputs #:allow-other-keys)
@@ -1160,9 +1161,9 @@ (define-public femtolisp
              (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (bin (string-append out "/bin")))
-                (and
-                 (zero? (system* "./bootstrap.sh"))
-                 (install-file "flisp.boot" bin))))))))
+                (invoke "./bootstrap.sh")
+                (install-file "flisp.boot" bin)
+                #t))))))
       (synopsis "Scheme-like lisp implementation")
       (description
        "@code{femtolisp} is a scheme-like lisp implementation with a