From 751b7aad1e85152413ac244a6cb457f8cea9c265 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 7 Oct 2015 12:16:45 +0300
Subject: [PATCH] gnu: gprolog: Remove armhf from supported architectures.

* gnu/packages/gprolog.scm (gprolog)[supported-systems]: Remove
  armhf-linux from the list of supported systems.
---
 gnu/packages/gprolog.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/gprolog.scm b/gnu/packages/gprolog.scm
index 8c41bf46821..1d9b9943bc6 100644
--- a/gnu/packages/gprolog.scm
+++ b/gnu/packages/gprolog.scm
@@ -18,10 +18,11 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages gprolog)
+  #:use-module (guix download)
   #:use-module (guix licenses)
   #:use-module (guix packages)
-  #:use-module (guix download)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (srfi srfi-1))
 
 (define-public gprolog
   (package
@@ -55,4 +56,6 @@ (define-public gprolog
     (license (list gpl2+ lgpl3+))
 
     ;; See 'configure' for the list of supported architectures.
-    (supported-systems (delete "mips64el-linux" %supported-systems))))
+    (supported-systems (fold delete
+                             %supported-systems
+                             '("armhf-linux" "mips64el-linux")))))
-- 
GitLab