From 75f796bb73a4cb4a06955fac19ef9af6f126988d Mon Sep 17 00:00:00 2001
From: Marius Bakke <mbakke@fastmail.com>
Date: Wed, 10 May 2017 16:17:21 +0200
Subject: [PATCH] gnu: e2fsprogs: Enable tests.

* gnu/packages/linux.scm (e2fsprogs)[native-inputs]: Add PERL and PROCPS.
[arguments]<#:tests?>: Remove.
---
 gnu/packages/linux.scm | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index eb7c5d14aed..61c960bfbe5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -659,7 +659,11 @@ (define-public e2fsprogs
     (build-system gnu-build-system)
     (inputs `(("util-linux" ,util-linux)))
     (native-inputs `(("pkg-config" ,pkg-config)
-                     ("texinfo" ,texinfo)))     ;for the libext2fs Info manual
+                     ("texinfo" ,texinfo)       ;for the libext2fs Info manual
+
+                     ;; For tests.
+                     ("perl" ,perl)
+                     ("procps" ,procps)))
     (arguments
      '(;; util-linux is the preferred source for some of the libraries and
        ;; commands, so disable them (see, e.g.,
@@ -710,12 +714,7 @@ (define-public e2fsprogs
                         (for-each (lambda (file)
                                     (chmod file #o666))
                                   archives)
-                        #t))))))
-
-       ;; FIXME: Tests work by comparing the stdout/stderr of programs, that
-       ;; they fail because we get an extra line that says "Can't check if
-       ;; file system is mounted due to missing mtab file".
-       #:tests? #f))
+                        #t))))))))
     (home-page "http://e2fsprogs.sourceforge.net/")
     (synopsis "Creating and checking ext2/ext3/ext4 file systems")
     (description
-- 
GitLab