diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a007e02e79263ef61ed222ad98ac89b8f60e7782..a528b7af13099c00d4b1930dbdd62a4b01d04d37 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -570,7 +570,7 @@ (define-public mupdf
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://mupdf.com/downloads/archive/"
+        (uri (string-append "https://mupdf.com/downloads/archive/"
                             name "-" version "-source.tar.gz"))
         (sha256
          (base32
@@ -615,7 +615,7 @@ (define-public mupdf
                            (string-append "prefix=" (assoc-ref %outputs "out")))
         #:phases (modify-phases %standard-phases
                   (delete 'configure))))
-    (home-page "http://mupdf.com")
+    (home-page "https://mupdf.com")
     (synopsis "Lightweight PDF viewer and toolkit")
     (description
       "MuPDF is a C library that implements a PDF and XPS parsing and