From 78c556636509515080a66511f1998a974d0e2623 Mon Sep 17 00:00:00 2001
From: humanitiesNerd <catonano@gmail.com>
Date: Sun, 12 Mar 2017 20:46:38 +0100
Subject: [PATCH] gnu: Add python-flask-htmlmin.

* gnu/packages/python.scm (python-flask-htmlmin, python2-flask-htmlmin): New
variables.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
---
 gnu/packages/python.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d77014d5c6a..f307b5c5b55 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13622,3 +13622,27 @@ (define-public python-htmlmin
 
 (define-public python2-htmlmin
   (package-with-python2 python-htmlmin))
+
+(define-public python-flask-htmlmin
+  (package
+    (name "python-flask-htmlmin")
+    (version "1.2")
+    (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-HTMLmin" version))
+      (sha256
+       (base32
+        "1n6zlq72kakkw0z2jpq6nh74lfsmxybm4g053pwhc14fbr809348"))))
+    (propagated-inputs
+     `(("python-flask" ,python-flask)
+       ("python-htmlmin" ,python-htmlmin)))
+    (build-system python-build-system)
+    (home-page "https://github.com/hamidfzm/Flask-HTMLmin")
+    (synopsis "HTML response minifier for Flask")
+    (description
+     "Minify @code{text/html} MIME type responses when using @code{Flask}.")
+    (license license:bsd-3)))
+
+(define-public python2-flask-htmlmin
+  (package-with-python2 python-flask-htmlmin))
-- 
GitLab