From 79624befa1a41e0ea237a4654209a1c08524374c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 19 Oct 2020 23:43:16 +0200
Subject: [PATCH] gnu: r-with-tests: Work around reproducibility problem.

Fixes <https://bugs.gnu.org/35441>.

* gnu/packages/statistics.scm (r-with-tests)[arguments]: Avoid reproducibility
problem by patching problematic sequence of characters in DESCRIPTION file
template.
---
 gnu/packages/statistics.scm | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index bebd574f418..3f65e6afa52 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -269,6 +269,15 @@ (define r-with-tests
                (substitute* "tools/help2man.pl"
                  (("my \\$date = strftime \"%B %Y\", localtime" line)
                   (string-append line " 1"))))
+
+             ;; The "References" section of this file when converted to
+             ;; package.rds is sometimes stored with a newline, sometimes with
+             ;; a space.  We avoid this problem by adding characters to break
+             ;; up the series of line break and spaces that is suspected to be
+             ;; the culprit.
+             (substitute* "src/library/methods/DESCRIPTION.in"
+               (("  ``Software")
+                "  -- ``Software"))
              #t))
          (add-before 'build 'set-locales
            (lambda _
-- 
GitLab