From 797585746b1e74aa47f06f0e757cbb6c0a262088 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 19 Jan 2021 10:33:19 +0200
Subject: [PATCH] gnu: freebayes: Extend test timeout on slower architectures.

* gnu/packages/bioinformatics.scm (freebayes)[arguments]: Use custom
'check phase  on aarch64-linux and armhf-linux to extend the test timeout.
---
 gnu/packages/bioinformatics.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9d9cd059692..908ae8a1948 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -143,6 +143,7 @@ (define-module (gnu packages bioinformatics)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-26)
   #:use-module (ice-9 match))
 
 (define-public aragorn
@@ -15168,7 +15169,16 @@ (define-public freebayes
                 (unpack "vcflib-src" "vcflib")
                 (unpack "intervaltree-src" "vcflib/intervaltree")
                 (unpack "test-simple-bash-src" "test/test-simple-bash"))
-               #t))))))
+               #t)))
+        ;; The slow tests take longer than the specified timeout.
+        ,@(if (any (cute string=? <> (%current-system))
+                   '("armhf-linux" "aarch64-linux"))
+            '((replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (invoke "meson" "test" "--timeout-multiplier" "5"))
+                #t)))
+            '()))))
     (home-page "https://github.com/ekg/freebayes")
     (synopsis "Haplotype-based variant detector")
     (description "FreeBayes is a Bayesian genetic variant detector designed to
-- 
GitLab