From 7ef08efa21900e6e43415b9f9db0e51a04e17fa5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Uko=20Kok=C5=86evi=C4=8Ds?= <perkontevs@gmail.com>
Date: Mon, 20 May 2019 02:23:30 +0300
Subject: [PATCH] gnu: libnotify: Propagate required inputs.

libnotify doesn't propagate other needed libraries for linking against
it resulting in pkg-config errors like

> Package gdk-pixbuf-2.0 was not found in the pkg-config search path.
> Perhaps you should add the directory containing `gdk-pixbuf-2.0.pc'
> to the PKG_CONFIG_PATH environment variable

* gnu/packages/gnome.scm (libnotify)[inputs]: Move GLIB and GDK-PIXBUF ...
[propagated-inputs]: ... here.  New field.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
---
 gnu/packages/gnome.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9671c21a9d7..8f23935ff63 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1108,10 +1108,12 @@ (define-public libnotify
        (base32
         "017wgq9n00hx39n0hm784zn18hl721hbaijda868cm96bcqwxd4w"))))
     (build-system gnu-build-system)
+    (propagated-inputs
+     `(;; In Requires of libnotify.pc.
+       ("gdk-pixbuf" ,gdk-pixbuf)
+       ("glib" ,glib)))
     (inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)
-       ("gtk+" ,gtk+)
+     `(("gtk+" ,gtk+)
        ("libpng" ,libpng)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
-- 
GitLab