diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ea24be2058676cae0f168922dc8e87751e18d1f5..485162ac90c72a34c7e6c4f1a1f7cd3de50baf9f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -505,7 +505,10 @@ (define-public go-github-com-kardianos-osext
                   "056dkgxrqjj5r18bnc3knlpgdz5p3yvp12y4y978hnsfhwaqvbjz"))))
       (build-system go-build-system)
       (arguments
-       `(#:import-path "github.com/kardianos/osext"))
+       `(#:import-path "github.com/kardianos/osext"
+         ;; The tests are flaky:
+         ;; <https://github.com/kardianos/osext/issues/21>
+         #:tests? #f))
       (synopsis "Find the running executable")
       (description "Osext provides a method for finding the current executable
 file that is running.  This can be used for upgrading the current executable or