From 81c29cccaad8760fec6f3673a80648e942b79f8b Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 29 Dec 2015 12:36:01 +0200
Subject: [PATCH] gnu: mpv: Add features.

* gnu/packages/video.scm (mpv)[inputs]: Add libvdpau.
[arguments]: Add gpl3 and zsh completion flags.
---
 gnu/packages/video.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 82f62a40776..6fd2300f0a7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -707,7 +707,7 @@ (define-public mpv
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-docutils" ,python-docutils)))
-    ;; Missing features: libguess, Wayland, VDPAU, V4L2
+    ;; Missing features: libguess, Wayland, V4L2
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("enca" ,enca)
@@ -724,6 +724,7 @@ (define-public mpv
        ("libdvdnav" ,libdvdnav)
        ("libjpeg" ,libjpeg)
        ("libva" ,libva)
+       ("libvdpau" ,libvdpau)
        ("libx11" ,libx11)
        ("libxext" ,libxext)
        ("libxinerama" ,libxinerama)
@@ -754,6 +755,7 @@ (define-public mpv
           (lambda* (#:key inputs #:allow-other-keys)
             (copy-file (assoc-ref inputs "waf") "waf")
             (setenv "CC" "gcc"))))
+       #:configure-flags (list "--enable-gpl3" "--enable-zsh-comp")
        ;; No check function defined.
        #:tests? #f))
     (home-page "http://mpv.io/")
-- 
GitLab