From 8331e2357b67e1b6b2f43ccaf904d7752e124645 Mon Sep 17 00:00:00 2001
From: Ivan Kozlov <kanichos@yandex.ru>
Date: Sun, 14 Jun 2020 11:48:59 +0200
Subject: [PATCH] gnu: xl2tpd: Add pppd support.

* gnu/packages/vpn.scm (xl2tpd)[inputs]: Add "linux-libre-headers" and "ppp",
[arguments]: add a 'setup-environment phase to set "PPPD" and "KERNELSRC"
variables.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
---
 gnu/packages/vpn.scm | 17 +++++++++++++++--
 1 file changed, 15 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a0aff7a32c2..4a26ced8240 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -13,6 +13,7 @@
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,6 +58,7 @@ (define-module (gnu packages vpn)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages python-web)
+  #:use-module (gnu packages samba)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
 
@@ -643,9 +645,20 @@ (define-public xl2tpd
      `(#:make-flags (list (string-append "PREFIX=" %output)
                           "CC=gcc")
        #:phases (modify-phases %standard-phases
-                  (delete 'configure))  ; no configure script
+                  (delete 'configure) ;no configure script
+                  (add-before 'build 'setup-environment
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (setenv "CFLAGS"
+                              (string-append "-DPPD=\""
+                                             (assoc-ref inputs "ppp")
+                                             "/sbin/pppd\""))
+                      (setenv "KERNELSRC"
+                              (assoc-ref inputs "linux-libre-headers"))
+                      #t)))
        #:tests? #f))                    ; no tests provided
-    (inputs `(("libpcap" ,libpcap)))
+    (inputs `(("libpcap" ,libpcap)
+              ("linux-libre-headers" ,linux-libre-headers)
+              ("ppp" ,ppp)))
     (home-page "https://www.xelerance.com/software/xl2tpd/")
     (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
     (description
-- 
GitLab