diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9dc5f5cd405f06ed84d9a6ee09f551961e61749d..53368251b50da6ce1b1525eaa070d15cc400d61c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -292,6 +292,11 @@ (define-public linux-libre
                  (alist-replace
                   'install ,install-phase
                   (alist-delete 'configure %standard-phases)))
+
+       ;; Use '--strip-debug', not '--strip-all', because the latter leads to
+       ;; unloadable modules (due to the lack of a symbol table.)
+       #:strip-flags '("--strip-debug")
+
        #:tests? #f))
     (synopsis "100% free redistribution of a cleaned Linux kernel")
     (description
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index c675155a6a135e322381f68bb6dfde1d976685a4..f765a144c413f6ddc3a9c9d969ec410feaf2cccb 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -274,7 +274,7 @@ (define* (gnu-build store name input-drvs
                     (parallel-tests? #t)
                     (patch-shebangs? #t)
                     (strip-binaries? #t)
-                    (strip-flags ''("--strip-debug"))
+                    (strip-flags ''("--strip-all"))
                     (strip-directories ''("lib" "lib64" "libexec"
                                           "bin" "sbin"))
                     (phases '%standard-phases)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 4cc755f3a6c86e2510abde00937d10f25f8a53ae..d661736831ea376fcebfd1f30fffee5cc38926c9 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -295,7 +295,7 @@ (define* (strip #:key target outputs (strip-binaries? #t)
                 (objcopy-command (if target
                                      (string-append target "-objcopy")
                                      "objcopy"))
-                (strip-flags '("--strip-debug"))
+                (strip-flags '("--strip-all"))
                 (strip-directories '("lib" "lib64" "libexec"
                                      "bin" "sbin"))
                 #:allow-other-keys)