diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1071abdbade9f6bf8642069732e825d3b8d7284a..0ab6aa8f479f8a284c2d4105121eac3e9bea1a77 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -360,6 +360,30 @@ (define-public python-pytest-pycodestyle
 for the @code{pytest} framework.")
     (license license:expat)))
 
+(define-public python-pytest-benchmark
+  (package
+    (name "python-pytest-benchmark")
+    (version "3.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-benchmark" version))
+       (sha256
+        (base32
+         "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-py-cpuinfo" ,python-py-cpuinfo)))
+    (native-inputs
+     `(("python-pathlib2" ,python-pathlib2)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/ionelmc/pytest-benchmark")
+    (synopsis "Pytest fixture for benchmarking code")
+    (description
+     "This package provides a pytest fixture that will group the tests into
+rounds that are calibrated to the chosen timer.")
+    (license license:bsd-2)))
+
 (define-public python-codacy-coverage
   (package
     (name "python-codacy-coverage")