diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 0207bcbad2a4c5fd9a848b632e7c965954fb7271..4410c5bc4396992ec4135174718f9b6524fe4b3c 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -85,12 +85,7 @@ (define-public mozjs
     (synopsis "Mozilla javascript engine")
     (description "SpiderMonkey is Mozilla's JavaScript engine written
 in C/C++.")
-    (license license:mpl2.0)                      ;and others for some files
-
-    ;; On mips64el, this fails to build with several "control reaches end of
-    ;; non-void function" errors (see
-    ;; <http://hydra.gnu.org/build/407741/nixlog/3/raw>.)
-    (supported-systems (delete "mips64el-linux" %supported-systems))))
+    (license license:mpl2.0))) ; and others for some files
 
 (define-public nspr
   (package