diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0c2c3e5e4991c4cdaad118ce37f65f9e7ce508ed..710fd2d29957258596de9dc21e9419c2cb958a0e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -424,8 +424,8 @@ (define* (make-linux-libre version hash supported-systems
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %linux-libre-version "5.0.6")
-(define %linux-libre-hash "0zznxchsdljw4swnr4i0qlvdww7cxskmil1691baj53xjv3wsh3n")
+(define %linux-libre-version "5.0.7")
+(define %linux-libre-hash "0c8g20crv03xxxpirj0jylcxxy33dn9f9x7viv451rzh9frc5mal")
 
 (define %linux-libre-5.0-patches
   (list %boot-logo-patch