From 88c85a940335f6cd5472f9dff7ade29753ea5353 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 15 Feb 2019 17:28:53 +0100
Subject: [PATCH] gnu: chez-matchable: Don't use unstable tarball.

* gnu/packages/chez.scm (chez-matchable)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
---
 gnu/packages/chez.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index fcf2a09bdc6..04371c74133 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -435,11 +435,13 @@ (define-public chez-matchable
     (home-page "https://github.com/fedeinthemix/chez-matchable")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append home-page "/archive" "/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "0cl4vc6487pikjq159pj4n5ghyaax31nywb5n4yn1682h3ir1hs0"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+        (base32 "02qn7x348p23z1x5lwhkyj7i8z6mgwpzpnwr8dyina0yzsdkr71s"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (inputs
      `(("chez-srfi" ,chez-srfi))) ; for tests
-- 
GitLab