From 8a4c98889270c163581231692fef64d9433b101f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Sun, 18 Dec 2016 12:09:13 +0100
Subject: [PATCH] build: check-final-inputs-self-contained has an exception for
 'bash:include'.

Currently 'bash:include' of the final Bash depends on bootstrap stuff.

* build-aux/check-final-inputs-self-contained.scm (final-inputs): Add
clause for 'bash:include'.
* gnu/packages/commencement.scm (bash-final): Add FIXME comment.
---
 build-aux/check-final-inputs-self-contained.scm | 7 ++++++-
 gnu/packages/commencement.scm                   | 1 +
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/build-aux/check-final-inputs-self-contained.scm b/build-aux/check-final-inputs-self-contained.scm
index 255286be29e..dc44c4b636f 100644
--- a/build-aux/check-final-inputs-self-contained.scm
+++ b/build-aux/check-final-inputs-self-contained.scm
@@ -37,12 +37,17 @@ (define (final-inputs store system)
                 (let ((drv (package-derivation store package system)))
                   ;; Libc's 'debug' output refers to gcc-cross-boot0, but it's
                   ;; hard to avoid, so we tolerate it.  This should be the
-                  ;; only exception.
+                  ;; only exception.  Likewise, 'bash:include' depends on
+                  ;; bootstrap-binaries via its 'Makefile.inc' (FIXME).
                   (filter-map (match-lambda
                                (("debug" . directory)
                                 (if (string=? "glibc" (package-name package))
                                     #f
                                     directory))
+                               (("include" . directory)
+                                (if (string=? "bash" (package-name package))
+                                    #f
+                                    directory))
                                ((_ . directory) directory))
                               (derivation->output-paths drv)))))
               %final-inputs))
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 2431babcada..c7aa59e9a22 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -783,6 +783,7 @@ (define %boot3-inputs
 (define bash-final
   ;; Link with `-static-libgcc' to make sure we don't retain a reference
   ;; to the bootstrap GCC.
+  ;; FIXME: This depends on 'bootstrap-binaries' via Makefile.in.
   (package-with-bootstrap-guile
    (package-with-explicit-inputs (static-libgcc-package bash)
                                  %boot3-inputs
-- 
GitLab