From 8c43746f359cd9d8590b2b6bad0fc9544dd7481f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Mon, 6 Oct 2014 09:45:17 +0200
Subject: [PATCH] gnu: libdaemon: Add alternate source URLs.

Fixes <http://bugs.gnu.org/18639>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/libdaemon.scm (libdaemon)[source]: Add Debian and Fedora
  mirrors.
---
 gnu/packages/libdaemon.scm | 24 ++++++++++++++++++------
 1 file changed, 18 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/libdaemon.scm b/gnu/packages/libdaemon.scm
index 0c77e280acf..24f5b51b293 100644
--- a/gnu/packages/libdaemon.scm
+++ b/gnu/packages/libdaemon.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,15 +28,27 @@ (define-public libdaemon
     (version "0.14")
     (source (origin
              (method url-fetch)
-             (uri (string-append
-                   "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
-                   version
-                   ".tar.gz"))
+             (uri (list
+                   (string-append
+                    "mirror://debian/pool/main/libd/libdaemon/libdaemon_"
+                    version ".orig.tar.gz")
+                   "http://pkgs.fedoraproject.org/repo/pkgs/libdaemon/libdaemon-0.14.tar.gz/509dc27107c21bcd9fbf2f95f5669563/libdaemon-0.14.tar.gz"
+
+                   ;; This used to be the canonical URL but it vanished.
+                   ;; See <http://bugs.gnu.org/18639>.
+                   ;; (string-append
+                   ;;  "http://0pointer.de/lennart/projects/libdaemon/libdaemon-"
+                   ;;  version ".tar.gz")
+                   ))
              (sha256
               (base32
-               "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))))
+               "0d5qlq5ab95wh1xc87rqrh1vx6i8lddka1w3f1zcqvcqdxgyn8zx"))
+             (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
+
+    ;; XXX: Stale URL, missing replacement.  See <http://bugs.gnu.org/18639>.
     (home-page "http://0pointer.de/lennart/projects/libdaemon/")
+
     (synopsis "Lightweight C library that eases the writing of UNIX daemons")
     (description
      "libdaemon is a lightweight C library that eases the writing of UNIX
-- 
GitLab