From 8e5e7299d190e10238e020e36f4b1c036f32d949 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 12 Jul 2013 22:25:30 +0200
Subject: [PATCH] gnu: plotutils: Allow compilation with newer libpng.

* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/patches/plotutils-libpng-jmpbuf.patch: New file.
* gnu/packages/plotutils.scm (plotutils): Add
  `plotutils-libpng-jmpbuf.patch' as an input, and apply it.
---
 gnu-system.am                                 |  5 ++--
 .../patches/plotutils-libpng-jmpbuf.patch     | 23 +++++++++++++++++++
 gnu/packages/plotutils.scm                    |  8 +++++--
 3 files changed, 32 insertions(+), 4 deletions(-)
 create mode 100644 gnu/packages/patches/plotutils-libpng-jmpbuf.patch

diff --git a/gnu-system.am b/gnu-system.am
index 41871ed0216..1877b7c39ec 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -189,7 +189,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/glib-tests-prlimit.patch			\
   gnu/packages/patches/glibc-bootstrap-system.patch		\
   gnu/packages/patches/glibc-no-ld-so-cache.patch		\
-  gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch \
+  gnu/packages/patches/gnutls-fix-tests-on-32-bits-system.patch	\
   gnu/packages/patches/grub-gets-undeclared.patch		\
   gnu/packages/patches/guile-1.8-cpp-4.5.patch			\
   gnu/packages/patches/guile-default-utf8.patch			\
@@ -204,8 +204,9 @@ dist_patch_DATA =						\
   gnu/packages/patches/make-impure-dirs.patch			\
   gnu/packages/patches/mcron-install.patch			\
   gnu/packages/patches/perl-no-sys-dirs.patch			\
-  gnu/packages/patches/python-fix-dbm.patch			\
+  gnu/packages/patches/plotutils-libpng-jmpbuf.patch		\
   gnu/packages/patches/procps-make-3.82.patch			\
+  gnu/packages/patches/python-fix-dbm.patch			\
   gnu/packages/patches/qemu-multiple-smb-shares.patch		\
   gnu/packages/patches/readline-link-ncurses.patch		\
   gnu/packages/patches/scheme48-tests.patch			\
diff --git a/gnu/packages/patches/plotutils-libpng-jmpbuf.patch b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
new file mode 100644
index 00000000000..07ef60996cd
--- /dev/null
+++ b/gnu/packages/patches/plotutils-libpng-jmpbuf.patch
@@ -0,0 +1,23 @@
+Use the `png_jmpbuf' accessor, as recommended since libpng 1.4.0:
+http://www.libpng.org/pub/png/src/libpng-1.2.x-to-1.4.x-summary.txt .
+
+--- plotutils-2.6/libplot/z_write.c	2013-07-12 17:19:12.000000000 +0200
++++ plotutils-2.6/libplot/z_write.c	2013-07-12 17:19:07.000000000 +0200
+@@ -164,7 +164,7 @@ _pl_z_maybe_output_image (S___(Plotter *
+     }
+ 
+   /* cleanup after libpng errors (error handler does a longjmp) */
+-  if (setjmp (png_ptr->jmpbuf))
++  if (setjmp (png_jmpbuf (png_ptr)))
+     {
+       png_destroy_write_struct (&png_ptr, (png_info **)NULL);
+       return -1;
+@@ -444,7 +444,7 @@ _our_error_fn_stdio (png_struct *png_ptr
+ #endif
+     }
+ 
+-  longjmp (png_ptr->jmpbuf, 1);
++  longjmp (png_jmpbuf (png_ptr), 1);
+ }
+ 
+ static void 
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 3080d74c4c8..a3c43d79baf 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -22,7 +22,8 @@ (define-module (gnu packages plotutils)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages xorg)
-  #:use-module (gnu packages libpng))
+  #:use-module (gnu packages libpng)
+  #:use-module (gnu packages))
 
 (define-public plotutils
   (package
@@ -36,10 +37,13 @@ (define-public plotutils
               (base32
                "1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))))
     (build-system gnu-build-system)
+    (arguments '(#:patches (list (assoc-ref %build-inputs "patch/jmpbuf"))))
     (inputs `(("libpng" ,libpng)
               ("libx11" ,libx11)
               ("libxt" ,libxt)
-              ("libxaw" ,libxaw)))
+              ("libxaw" ,libxaw)
+              ("patch/jmpbuf"
+               ,(search-patch "plotutils-libpng-jmpbuf.patch"))))
     (home-page
      "http://www.gnu.org/software/plotutils/")
     (synopsis "Plotting utilities and library")
-- 
GitLab