From 8ea6b30fea9637c5568c310d384bc13bc225648b Mon Sep 17 00:00:00 2001
From: Vicente Vera Parra <vicentemvp@gmail.com>
Date: Tue, 15 Sep 2015 14:14:11 -0300
Subject: [PATCH] gnu: Add r-dbi.

* gnu/packages/statistics.scm (r-dbi): New variable.
---
 gnu/packages/statistics.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 6bd8e767ec3..6ccb97f375b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -539,3 +539,24 @@ (define-public r-lazyeval
      "This package provides the tools necessary to do non-standard
 evaluation (NSE) in R.")
     (license license:gpl3+)))
+
+(define-public r-dbi
+  (package
+    (name "r-dbi")
+    (version "0.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cran/src/contrib/DBI_"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0xj5baxwnhl23rd5nskhjvranrwrc68f3xlyrklglipi41bm69hw"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/rstats-db/DBI")
+    (synopsis "R database interface")
+    (description
+     "The DBI package provides a database interface (DBI) definition for
+communication between R and relational database management systems.  All
+classes in this package are virtual and need to be extended by the various
+R/DBMS implementations.")
+    (license license:lgpl2.0+)))
-- 
GitLab