diff --git a/doc/guix.texi b/doc/guix.texi
index e1303179921cc516e14b275986f39c9601db4bfc..7a86a2f0ac8741f42971ea26979c49796c2f1016 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -9544,7 +9544,7 @@ Defaults to @samp{""}.
 @end deftypevr
 
 @deftypevr {@code{dovecot-configuration} parameter} boolean mail-full-filesystem-access?
-Allow full filesystem access to clients.  There's no access checks
+Allow full file system access to clients.  There's no access checks
 other than what the operating system does for the active UID/GID.  It
 works with both maildir and mboxes, allowing you to prefix mailboxes
 names with e.g. /path/ or ~user/.
@@ -9553,7 +9553,7 @@ Defaults to @samp{#f}.
 
 @deftypevr {@code{dovecot-configuration} parameter} boolean mmap-disable?
 Don't use mmap() at all.  This is required if you store indexes to
-shared filesystems (NFS or clustered filesystem).
+shared file systems (NFS or clustered file system).
 Defaults to @samp{#f}.
 @end deftypevr
 
@@ -9815,7 +9815,7 @@ Defaults to @samp{"1d"}.
 @deftypevr {@code{dovecot-configuration} parameter} boolean mdbox-preallocate-space?
 When creating new mdbox files, immediately preallocate their size to
 @samp{mdbox-rotate-size}.  This setting currently works only in Linux
-with some filesystems (ext4, xfs).
+with some file systems (ext4, xfs).
 Defaults to @samp{#f}.
 @end deftypevr
 
@@ -9838,7 +9838,7 @@ Defaults to @samp{128000}.
 @end deftypevr
 
 @deftypevr {@code{dovecot-configuration} parameter} string mail-attachment-fs
-Filesystem backend to use for saving attachments:
+File system backend to use for saving attachments:
 @table @code
 @item posix
 No SiS done by Dovecot (but this might help FS's own deduplication)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3685633f34c3db820bab0d09d8f7fbf4f208836d..6d6961752f2c1ed325c371f94a75bb9cde363e9e 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1461,9 +1461,9 @@ (define-public autojump
                           `("PYTHONPATH" ":" prefix (,py)))
                         #t))))))
     (home-page "https://github.com/wting/autojump")
-    (synopsis "Shell extension for filesystem navigation")
+    (synopsis "Shell extension for file system navigation")
     (description
-     "Autojump provides a faster way to navigate your filesystem, with a \"cd
+     "Autojump provides a faster way to navigate your file system, with a \"cd
 command that learns\".  It works by maintaining a database of the directories
 you use the most from the command line and allows you to \"jump\" to
 frequently used directories by typing only a small pattern.")
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 4263cdebb777924f8b065a740c7c68b1ce928692..52c90e18e40f575e37edf2112e9b7334a22b69ed 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -146,10 +146,10 @@ (define-public xorriso
        ("zlib" ,zlib)
        ("libcdio" ,libcdio)))
     (home-page "https://www.gnu.org/software/xorriso/")
-    (synopsis "Create, manipulate, burn ISO-9660 filesystems")
+    (synopsis "Create, manipulate, burn ISO-9660 file systems")
     (description
      "GNU Xorriso is a tool for copying files to and from ISO 9660 Rock
-Ridge, a.k.a. Compact Disc File System, filesystems and it allows
+Ridge, a.k.a. Compact Disc File System, file systems and it allows
 session-wise manipulation of them.  It features a formatter and burner for
 CD, DVD and BD.  It can operate on existing ISO images or it can create new
 ones.  xorriso can then be used to copy files directly into or out of ISO
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index aaa0c99e883410fba38f077646d51034d95736b5..6504641977eb51b81a589e9073e4607ddf81f91a 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -664,14 +664,14 @@ (define-public squashfs-tools
        ("xz" ,xz)
        ("zlib" ,zlib)))
     (home-page "http://squashfs.sourceforge.net/")
-    (synopsis "Tools to create and extract squashfs filesystems")
+    (synopsis "Tools to create and extract squashfs file systems")
     (description
-     "Squashfs is a highly compressed read-only filesystem for Linux.  It uses
+     "Squashfs is a highly compressed read-only file system for Linux.  It uses
 zlib to compress files, inodes, and directories.  All blocks are packed to
 minimize the data overhead, and block sizes of between 4K and 1M are supported.
 It is intended to be used for archival use, for live CDs, and for embedded
 systems where low overhead is needed.  This package allows you to create and
-extract such filesystems.")
+extract such file systems.")
     (license license:gpl2+)))
 
 (define-public pigz
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 27ab7a698bbd8ae5f1a4a2f683f53e54b249c6e8..a3ace8ab16e64b96b69eab39ce574cde020d7fb6 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -191,10 +191,10 @@ (define-public dosfstools
                           "CC=gcc")
        #:tests? #f))  ;no tests
     (home-page "https://github.com/dosfstools/dosfstools")
-    (synopsis "Utilities for making and checking MS-DOS FAT filesystems")
+    (synopsis "Utilities for making and checking MS-DOS FAT file systems")
     (description
      "The dosfstools package includes the mkfs.fat and fsck.fat utilities,
-which respectively make and check MS-DOS FAT filesystems.")
+which respectively make and check MS-DOS FAT file systems.")
     (license license:gpl3+)))
 
 (define-public sdparm
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6dab1d79e82152de2e49663a2795eba3ac7a4697..19e982d08a5e338a0df84abe44b0cc5455812ae2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3469,9 +3469,9 @@ (define-public gvfs
        ("nettle" ,nettle) ; XXX: required by libarchive.pc
        ("udisks" ,udisks)))
     (home-page "https://wiki.gnome.org/gvfs/")
-    (synopsis "Userspace virtual filesystem for GIO")
+    (synopsis "Userspace virtual file system for GIO")
     (description
-     "GVFS is a userspace virtual filesystem designed to work with the I/O
+     "GVFS is a userspace virtual file system designed to work with the I/O
 abstraction of GIO.  It contains a GIO module that seamlessly adds GVFS support
 to all applications using the GIO API.  It also supports exposing the GVFS
 mounts to non-GIO applications using FUSE.
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index d52edd83731e88bdb0f43dd6d4a81696670e96bc..1058bef7780fc98cbe0f06fcd3179fefe15be4cd 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -262,9 +262,9 @@ (define-public ii
        (modify-phases %standard-phases
          (delete 'configure)))) ; no configure
     (home-page "http://tools.suckless.org/ii/")
-    (synopsis "FIFO and filesystem-based IRC client")
+    (synopsis "FIFO and file system based IRC client")
     (description
-     "ii (Irc it) is a minimalist FIFO and filesystem based IRC client.")
+     "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
     (license license:expat)))
 
 (define-public sic
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index df2eb6842629d6d358b04b68f82fb34d77a25971..3e4237720b472ece42fd10f2dcf5ae7a8e79b38a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -420,10 +420,10 @@ (define-public psmisc
     (inputs `(("ncurses" ,ncurses)))
     (home-page "http://psmisc.sourceforge.net/")
     (synopsis
-     "Small utilities that use the proc filesystem")
+     "Small utilities that use the proc file system")
     (description
      "This PSmisc package is a set of some small useful utilities that
-use the proc filesystem.  We're not about changing the world, but
+use the proc file system.  We're not about changing the world, but
 providing the system administrator with some help in common tasks.")
     (license license:gpl2+)))
 
@@ -501,7 +501,7 @@ (define-public util-linux
     (home-page "https://www.kernel.org/pub/linux/utils/util-linux/")
     (synopsis "Collection of utilities for the Linux kernel")
     (description "Util-linux is a diverse collection of Linux kernel
-utilities.  It provides dmesg and includes tools for working with filesystems,
+utilities.  It provides dmesg and includes tools for working with file systems,
 block devices, UUIDs, TTYs, and many other tools.")
 
     ;; Note that util-linux doesn't use the same license for all the
@@ -643,7 +643,7 @@ (define-public e2fsprogs
 
        ;; FIXME: Tests work by comparing the stdout/stderr of programs, that
        ;; they fail because we get an extra line that says "Can't check if
-       ;; filesystem is mounted due to missing mtab file".
+       ;; file system is mounted due to missing mtab file".
        #:tests? #f))
     (home-page "http://e2fsprogs.sourceforge.net/")
     (synopsis "Creating and checking ext2/ext3/ext4 file systems")
@@ -2185,7 +2185,7 @@ (define-public sysfsutils
     (home-page "http://linux-diag.sourceforge.net/Sysfsutils.html")
     (synopsis "System utilities based on Linux sysfs")
     (description
-     "These are a set of utilities built upon sysfs, a virtual filesystem in
+     "These are a set of utilities built upon sysfs, a virtual file system in
 Linux kernel versions 2.5+ that exposes a system's device tree.  The package
 also contains the libsysfs library.")
     ;; The library is under lgpl2.1+ (all files say "or any later version").
@@ -2623,7 +2623,7 @@ (define-public btrfs-progs
                      ("which" ,which)))
     (home-page "https://btrfs.wiki.kernel.org/")
     (synopsis "Create and manage btrfs copy-on-write file systems")
-    (description "Btrfs is a copy-on-write (CoW) filesystem for Linux aimed at
+    (description "Btrfs is a copy-on-write (CoW) file system for Linux aimed at
 implementing advanced features while focusing on fault tolerance, repair and
 easy administration.")
     ;; GPL2+: crc32.c, radix-tree.c, raid6.c, rbtree.c.
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 90c2da4f10d028f5521e34df07d177cd0fc55f43..e344683af75b381b0a892591389f49440a48f5ee 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1213,7 +1213,7 @@ (define-public procmail
                       #t)))
        #:tests? #f)) ;; There are no tests indicating a successful
     ;; build.  Some tests of basic locking mechanisms provided by the
-    ;; filesystem are performed during 'make install'.  However, these
+    ;; file system are performed during 'make install'.  However, these
     ;; are performed before the actual build process.
     (build-system gnu-build-system)
     (inputs `(("exim" ,exim)))
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 7bf39f98b7b87ee74120cbd25026f4820a63d42d..ec0861db11b528438902e2ee9227e6594364e09d 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -208,7 +208,7 @@ (define-public ncmpcpp
     (description "Ncmpcpp is an mpd client with a UI very similar to ncmpc,
 but it provides new useful features such as support for regular expressions
 for library searches, extended song format, items filtering, the ability to
-sort playlists, and a local filesystem browser.")
+sort playlists, and a local file system browser.")
     (home-page "http://ncmpcpp.rybczak.net/")
     (license license:gpl2+)))
 
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1f4c3e471af91c03ec11a95eee01a4e72315410c..f6f7308ff0792ccbaa5645fd63a269050a0dc3e9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -673,7 +673,7 @@ (define-public ocaml-findlib
      "The \"findlib\" library provides a scheme to manage reusable software
 components (packages), and includes tools that support this scheme.  Packages
 are collections of OCaml modules for which metainformation can be stored.  The
-packages are kept in the filesystem hierarchy, but with strict directory
+packages are kept in the file system hierarchy, but with strict directory
 structure.  The library contains functions to look the directory up that
 stores a package, to query metainformation about a package, and to retrieve
 dependency information about multiple packages.  There is also a tool that
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d42294044701c25db7f81f9424bb8187d1b519cb..ba6f71a412b46a58e8adda055ecf417b3a8a7e12 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -404,7 +404,7 @@ (define-public perl-cache-cache
 expensive calls to remote machines or databases.  People have also been known
 to use Cache::Cache for its straightforward interface in sharing data between
 runs of an application or invocations of a CGI-style script or simply as an
-easy to use abstraction of the filesystem or shared memory.")
+easy to use abstraction of the file system or shared memory.")
     (license (package-license perl))))
 
 (define-public perl-cache-fastmmap
@@ -2115,7 +2115,7 @@ (define-public perl-env-path
     (synopsis "Advanced operations on path variables")
     (description "@code{Env::Path} presents an object-oriented interface to
 path variables, defined as that subclass of environment variables which name
-an ordered list of filesystem elements separated by a platform-standard
+an ordered list of file system elements separated by a platform-standard
 separator.")
     (license (package-license perl))))
 
@@ -2461,7 +2461,7 @@ (define-public perl-file-path
     (synopsis "Create or remove directory trees")
     (description "This module provide a convenient way to create directories
 of arbitrary depth and to delete an entire directory subtree from the
-filesystem.")
+file system.")
     (license (package-license perl))))
 
 (define-public perl-file-list
@@ -6348,7 +6348,7 @@ (define-public perl-text-glob
     (home-page "http://search.cpan.org/dist/Text-Glob")
     (synopsis "Match globbing patterns against text")
     (description "Text::Glob implements glob(3) style matching that can be
-used to match against text, rather than fetching names from a filesystem.  If
+used to match against text, rather than fetching names from a file system.  If
 you want to do full file globbing use the File::Glob module instead.")
     (license (package-license perl))))
 
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0671444ca5806262151b9574c89e4382f7c79d91..2f349c88f3f0092ef0d4fcff9d10b2d7852616d5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6943,7 +6943,7 @@ (define-public python-atomicwrites
     (build-system python-build-system)
     (synopsis "Atomic file writes in Python")
     (description "Library for atomic file writes using platform dependent tools
-for atomic filesystem operations.")
+for atomic file system operations.")
     (home-page "https://github.com/untitaker/python-atomicwrites")
     (license license:expat)
     (properties `((python2-variant . ,(delay python2-atomicwrites))))))
@@ -8571,8 +8571,8 @@ (define-public python-pathlib
          (replace 'check
            (lambda _ (zero? (system* "python" "./test_pathlib.py")))))))
     (home-page "https://pathlib.readthedocs.org/")
-    (synopsis "Object-oriented filesystem paths")
-    (description "Pathlib offers a set of classes to handle filesystem paths.
+    (synopsis "Object-oriented file system paths")
+    (description "Pathlib offers a set of classes to handle file system paths.
 It offers the following advantages over using string objects:
 
 @enumerate
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 60f902f96aa75b74899e033bb76adf01f9d926a5..9eb4039f84a5afbd88932f408ab4f0e8e0c22844 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -165,7 +165,7 @@ (define-public mlocate
                 "0gi6y52gkakhhlnzy0p6izc36nqhyfx5830qirhvk3qrzrwxyqrh"))))
     (build-system gnu-build-system)
     (home-page "https://fedorahosted.org/mlocate/")
-    (synopsis "Locate files on the filesystem")
+    (synopsis "Locate files on the file system")
     (description
      "mlocate is a locate/updatedb implementation.  The 'm' stands for
 \"merging\": @code{updatedb} reuses the existing database to avoid rereading
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 412ec77bc5cf5b53e99181a7437aac0320c98dfb..076270380053159ca83c5487bd199465bde356fd 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -161,7 +161,7 @@ (define-public gnutls
              ;; the location of the system-wide trust store.  Instead it has a
              ;; configure-time option.  Unless specified, its configure script
              ;; attempts to auto-detect the location by looking for common
-             ;; places in the filesystem, none of which are present in our
+             ;; places in the file system, none of which are present in our
              ;; chroot build environment.  If not found, then no default trust
              ;; store is used, so each program has to provide its own
              ;; fallback, and users have to configure each program
diff --git a/gnu/services/mail.scm b/gnu/services/mail.scm
index 46dbab6645ec0649381a5fae70d08eb9844b16d6..d94532c353c84315d2f1e92464a4e51d950c4160 100644
--- a/gnu/services/mail.scm
+++ b/gnu/services/mail.scm
@@ -987,7 +987,7 @@ (define-configuration dovecot-configuration
 
   (mail-full-filesystem-access?
    (boolean #f)
-   "Allow full filesystem access to clients.  There's no access checks
+   "Allow full file system access to clients.  There's no access checks
 other than what the operating system does for the active UID/GID.  It
 works with both maildir and mboxes, allowing you to prefix mailboxes
 names with e.g. /path/ or ~user/.")
@@ -997,7 +997,7 @@ (define-configuration dovecot-configuration
   (mmap-disable?
    (boolean #f)
    "Don't use mmap() at all.  This is required if you store indexes to
-shared filesystems (NFS or clustered filesystem).")
+shared file systems (NFS or clustered file system).")
 
   (dotlock-use-excl?
    (boolean #t)
@@ -1229,7 +1229,7 @@ (define-configuration dovecot-configuration
    (boolean #f)
    "When creating new mdbox files, immediately preallocate their size to
 @samp{mdbox-rotate-size}.  This setting currently works only in Linux
-with some filesystems (ext4, xfs).")
+with some file systems (ext4, xfs).")
 
   (mail-attachment-dir
    (string "")
@@ -1249,7 +1249,7 @@ (define-configuration dovecot-configuration
 
   (mail-attachment-fs
    (string "sis posix")
-   "Filesystem backend to use for saving attachments:
+   "File system backend to use for saving attachments:
 @table @code
 @item posix
 No SiS done by Dovecot (but this might help FS's own deduplication)