diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a164048641c4498fb72b34822b86c0c3d799f163..2a982f417cd8c14b4dc174dc5c653ff91525c151 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5163,7 +5163,16 @@ (define-public http-parser
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))))
+                "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; There are signedness errors that trigger on 32-bit
+                  ;; platforms that trigger, and '-Werror' leads to build
+                  ;; failures.
+                  (substitute* "Makefile"
+                    (("-Werror") ""))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"