From 90b94761b673665e212e2677e5ed9924f9a6af42 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Tue, 16 Apr 2019 17:48:46 +0200
Subject: [PATCH] gnu: http-parser: Fix build on i686-linux.

Fixes a regression introduced in
c11fcc6aa27db5f68aed807a6190143f4a156564, whereby 'http-parser' would
fail to build on i686.

* gnu/packages/web.scm (http-parser)[source](modules, snippet): New
fields.
---
 gnu/packages/web.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a164048641c..2a982f417cd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5163,7 +5163,16 @@ (define-public http-parser
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))))
+                "12ilmjma6vmlm2kl23fx5pbi226x098gljgxpx3h2kmq8pg2lm28"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; There are signedness errors that trigger on 32-bit
+                  ;; platforms that trigger, and '-Werror' leads to build
+                  ;; failures.
+                  (substitute* "Makefile"
+                    (("-Werror") ""))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
-- 
GitLab