From 9128e323c0a23243c3f70b1716c68ad0b241f30d Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Fri, 17 Apr 2015 02:20:41 -0400
Subject: [PATCH] gnu: icecat: Use system sqlite.

* gnu/packages/gnuzilla.scm (icecat)[inputs]: Add sqlite.
  [arguments]: Pass "--enable-system-sqlite" to configure.
---
 gnu/packages/gnuzilla.scm | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 419ff7adb9a..522404f2803 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -253,6 +253,7 @@ (define-public icecat
        ("mesa" ,mesa)
        ("nspr" ,nspr)
        ("nss" ,nss)
+       ("sqlite" ,sqlite)
        ("unzip" ,unzip)
        ("yasm" ,yasm)
        ("zip" ,zip)
@@ -291,11 +292,7 @@ (define-public icecat
                            "--enable-system-pixman"
                            "--enable-system-cairo"
                            "--enable-system-ffi"
-
-                           ;; Fails with "configure: error: System
-                           ;; SQLite library is not compiled with
-                           ;; SQLITE_ENABLE_UNLOCK_NOTIFY."
-                           ;; "--enable-system-sqlite"
+                           "--enable-system-sqlite"
 
                            ;; Fails with "--with-system-png won't work because
                            ;; the system's libpng doesn't have APNG support".
-- 
GitLab