From 917239ff99468de351f93a019e9abe52f29adec7 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sat, 12 Nov 2016 18:33:45 +0100
Subject: [PATCH] =?UTF-8?q?gnu:=20tidy:=20Use=20=E2=80=98modify-phases?=
 =?UTF-8?q?=E2=80=99.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/web.scm (tidy)[arguments]: Use the ‘modify-phases’ syntax.
---
 gnu/packages/web.scm | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5237cc7b9e8..6cffc79db1f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,15 +510,14 @@ (module "tidy")
               (patches (search-patches "tidy-CVE-2015-5522+5523.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-cons-after
-                 'unpack 'bootstrap
-                 (lambda* (#:key inputs #:allow-other-keys)
-                   ;; configure.in and Makefile.am aren't in the root of the
-                   ;; source tree.
-                   (copy-recursively "build/gnuauto" ".")
-                   (setenv "AUTOMAKE" "automake --foreign")
-                   (zero? (system* "autoreconf" "-vfi")))
-                 %standard-phases)))
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'bootstrap
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      ;; configure.in and Makefile.am aren't in the root of the
+                      ;; source tree.
+                      (copy-recursively "build/gnuauto" ".")
+                      (setenv "AUTOMAKE" "automake --foreign")
+                      (zero? (system* "autoreconf" "-vfi")))))))
     (native-inputs
      `(("automake" ,automake)
        ("autoconf" ,autoconf)
-- 
GitLab