From 94b13427d766b030b02b2df6a291525335f2d08d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Wed, 23 Jul 2014 22:27:17 +0200
Subject: [PATCH] gnu: module-init-tools: Fix $LINUX_MODULE_DIRECTORY handling
 in 'depmod'.

* gnu/packages/patches/module-init-tools-moduledir.patch: Adjust the
  'depmod' part to handle $LINUX_MODULE_DIRECTORY without a trailing
  slash.
---
 gnu/packages/patches/module-init-tools-moduledir.patch | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/patches/module-init-tools-moduledir.patch b/gnu/packages/patches/module-init-tools-moduledir.patch
index 7a40a03b040..08f03d1cc4c 100644
--- a/gnu/packages/patches/module-init-tools-moduledir.patch
+++ b/gnu/packages/patches/module-init-tools-moduledir.patch
@@ -6,7 +6,7 @@ Original patch by David Guibert, from Nixpkgs; adjusted to use
 'LINUX_MODULE_DIRECTORY' rather than 'MODULE_DIR' as the variable name.
 
 diff --git a/depmod.c b/depmod.c
-index a1d2f8c..a8f92b2 100644
+index a1d2f8c..ff579c7 100644
 --- a/depmod.c
 +++ b/depmod.c
 @@ -48,9 +48,6 @@
@@ -77,7 +77,7 @@ index a1d2f8c..a8f92b2 100644
 +                module_dir = "/lib/modules";
 +        }
 +
-+	nofail_asprintf(&dirname, "%s%s%s", basedir, module_dir, version);
++	nofail_asprintf(&dirname, "%s%s/%s", basedir, module_dir, version);
  
  	if (maybe_all) {
  		if (!doing_stdout && !depfile_out_of_date(dirname))
-- 
GitLab