From 94c4a58a0acb7af0baf7301c39850d633390c4bc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Thu, 3 Oct 2013 23:05:21 +0200
Subject: [PATCH] gnu: Add Netcat.

* gnu/packages/system.scm (netcat): New variable.
---
 gnu/packages/system.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 35245447462..3115714b080 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -314,3 +314,26 @@ (define-public net-base
 ONC RPC numbers")
     (home-page "http://packages.debian.org/sid/netbase")
     (license gpl2)))
+
+(define-public netcat
+  (package
+    (name "netcat")
+    (version "0.7.1")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/netcat/netcat-"
+                                 version ".tar.bz2"))
+             (sha256
+              (base32
+               "1frjcdkhkpzk0f84hx6hmw5l0ynpmji8vcbaxg8h5k2svyxz0nmm"))))
+    (build-system gnu-build-system)
+    (home-page "http://netcat.sourceforge.net")
+    (synopsis "Read and write data over TCP/IP")
+    (description
+     "Netcat is a featured networking utility which reads and writes data
+across network connections, using the TCP/IP protocol.  It is designed to be a
+reliable \"back-end\" tool that can be used directly or easily driven by other
+programs and scripts. At the same time, it is a feature-rich network debugging
+and exploration tool, since it can create almost any kind of connection you
+would need and has several interesting built-in capabilities.")
+    (license gpl2+)))
-- 
GitLab