From 96693d1d92ba0d57cd47259e846bbb33c9076f32 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Wed, 24 Jun 2015 23:02:32 +0800
Subject: [PATCH] gnu: gstreamer: Add search path specification for
 'GST_PLUGIN_SYSTEM_PATH'.

This reverts commit e53fc0c8a, which add it wrongly to gst-plugins-base.

* gnu/packages/gstreamer.scm (gstreamer)[native-search-paths]: New field.
  (gst-plugins-base)[native-search-paths]: Remove.
---
 gnu/packages/gstreamer.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 24dc41b7033..18329097b05 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -109,6 +109,10 @@ (define-public gstreamer
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "GST_PLUGIN_SYSTEM_PATH")
+            (files '("lib/gstreamer-1.0")))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis "Multimedia library")
     (description
@@ -171,10 +175,6 @@ (define-public gst-plugins-base
           ;; for g-ir-scanner.
           (setenv "CC" "gcc"))
         %standard-phases)))
-    (native-search-paths
-     (list (search-path-specification
-            (variable "GST_PLUGIN_SYSTEM_PATH")
-            (files '("lib/gstreamer-1.0")))))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis
      "Plugins for the GStreamer multimedia library")
-- 
GitLab