From 96a469f1cdac9c3a1022eca3e7a3cb408b7464eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 15 Nov 2019 22:56:43 +0100
Subject: [PATCH] gnu: openmpi: Fix typo.

* gnu/packages/mpi.scm (openmpi)[inputs]: For UCX, check the supported
systems of UCX, not PSM2.
---
 gnu/packages/mpi.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5fde6efae47..30169f76d44 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -192,7 +192,7 @@ (define-public openmpi
              `(("psm2" ,psm2))
              '())
        ,@(if (and (not (%current-target-system))
-                  (member (%current-system) (package-supported-systems psm2)))
+                  (member (%current-system) (package-supported-systems ucx)))
              `(("ucx" ,ucx))
              '())
        ("rdma-core" ,rdma-core)
-- 
GitLab