From 9729b6ea2fe89d5b8cfd180ef2dfca367c7417e5 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Sun, 21 Apr 2019 10:33:18 +0100
Subject: [PATCH] gnu: direnv: Remove go references from output.

In the long run, it would be good to move direnv across to the
go-build-system, and update the package, but these changes do succeed in
reducing the closure size a lot.

Thanks to Tanguy Le Carrour for raising this issue on guix-devel.

* gnu/packages/shellutils.scm (direnv)[arguments]: Include the
remove-go-references phase from the go-build-system.
[inputs,native-inputs]: Move all inputs to native-inputs, as these are no
longer referenced in the output.
---
 gnu/packages/shellutils.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 88c0f32e99d..59a8b744eb4 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -128,13 +128,14 @@ (define-public direnv
          (delete 'configure)
          ;; Help the build scripts find the Go language dependencies.
          (add-before 'unpack 'setup-go-environment
-           (assoc-ref go:%standard-phases 'setup-go-environment)))))
-    (inputs
+           (assoc-ref go:%standard-phases 'setup-go-environment))
+         (add-after 'install 'remove-go-references
+           (assoc-ref go:%standard-phases 'remove-go-references)))))
+    (native-inputs
      `(("go" ,go)
        ("go-github-com-burntsushi-toml" ,go-github-com-burntsushi-toml)
-       ("go-github-com-direnv-go-dotenv" ,go-github-com-direnv-go-dotenv)))
-    (native-inputs
-      `(("which" ,which)))
+       ("go-github-com-direnv-go-dotenv" ,go-github-com-direnv-go-dotenv)
+       ("which" ,which)))
     (home-page "https://direnv.net/")
     (synopsis "Environment switcher for the shell")
     (description
-- 
GitLab