From 982a6e79a2d674ea905e2c63c2378b9df7d64af6 Mon Sep 17 00:00:00 2001
From: Jesse Gibbons <jgibbons2357@gmail.com>
Date: Tue, 21 Jul 2020 12:56:03 -0600
Subject: [PATCH] gnu: chroma: Configure with inline attribute.

* gnu/packages/games.scm (chroma)[configure-flags]: Add flag to properly
support inline attribute of STD C89.

Signed-off-by: Brett Gilio <brettg@gnu.org>
---
 gnu/packages/games.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 213acc6b9f8..1a6c569fa79 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -40,7 +40,7 @@
 ;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;; Copyright © 2019, 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
 ;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
 ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
@@ -5903,7 +5903,8 @@ (define-public chroma
                 "047sf00x71xbmi8bqrhfbmr9bk89l2gbykkqsfpw4wz6yfjscs6y"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f))                    ; no tests included
+     `(#:tests? #f                      ; no tests included
+       #:configure-flags '("CFLAGS=-fgnu89-inline"))) ; fix inlines
     (inputs
      `(("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf)))
        ("freetype" ,freetype)
-- 
GitLab