From 988cecfd4ff1f1d8e7960ed3f52f51af824a681b Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Tue, 1 Apr 2014 17:56:57 -0400
Subject: [PATCH] gnu: expect: Install man pages in share/man.

* gnu/packages/tcl.scm (expect): Add --mandir configure flag.
  Use 'let' to simplify configure flags generation.
---
 gnu/packages/tcl.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 18324ec94cf..3ebdcbe5e2a 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -95,14 +95,12 @@ (define-public expect
        ("tcl" ,tcl)))
     (arguments
      '(#:configure-flags
-       (list (string-append "--with-tcl="
-                            (assoc-ref %build-inputs "tcl")
-                            "/lib")
-             (string-append "--with-tclinclude="
-                            (assoc-ref %build-inputs "tcl")
-                            "/include")
-             (string-append "--exec-prefix="
-                            (assoc-ref %outputs "out")))
+       (let ((out (assoc-ref %outputs "out"))
+             (tcl (assoc-ref %build-inputs "tcl")))
+         (list (string-append "--with-tcl=" tcl "/lib")
+               (string-append "--with-tclinclude=" tcl "/include")
+               (string-append "--exec-prefix=" out)
+               (string-append "--mandir=" out "/share/man")))
 
        #:phases (alist-cons-before
                  'configure 'set-path-to-stty
-- 
GitLab