diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0a02d08ae30e12886af00a40f3e6ef4ef03be47a..25cd08faf25d3a1a4c3e9ab2a53ae024a9ba3fde 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2760,7 +2760,8 @@ (define-public clutter-gtk
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("gobject-introspection" ,gobject-introspection)))
-    (inputs
+    (propagated-inputs
+     ;; clutter-gtk.pc refers to all these.
      `(("clutter" ,clutter)
        ("gtk+" ,gtk+)))
     (home-page "http://www.clutter-project.org")