From 9ca3323608f183814a9313a08df3415075638aaf Mon Sep 17 00:00:00 2001
From: David Hashe <david.hashe@dhashe.com>
Date: Tue, 5 May 2015 01:48:28 -0500
Subject: [PATCH] gnu: webkitgtk: Fix compilation on x86_64.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/webkit.scm (webkitgtk): Move library install path from lib64 to
 lib.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/webkit.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index e6de8ab0df8..41b9b9a839f 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,7 +58,12 @@ (define-public webkitgtk
     (arguments
      '(#:tests? #f ; no tests
        #:build-type "Release" ; turn off debugging symbols to save space
-       #:configure-flags '("-DPORT=GTK")))
+       #:configure-flags (list
+                          "-DPORT=GTK"
+                          (string-append ; uses lib64 by default
+                           "-DLIB_INSTALL_DIR="
+                           (assoc-ref %outputs "out") "/lib"))
+       #:make-flags '("lib=lib"))) ; uses lib64 by default
     (native-inputs
      `(("bison" ,bison)
        ("gettext" ,gnu-gettext)
-- 
GitLab