diff --git a/Makefile.am b/Makefile.am
index afbf4eb20a55d4ecef6a8ebf53aa8a27a39f0806..d9d7ffd6c5325a49b35a1f7d5a084faad3cc9018 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -818,6 +818,7 @@ release: dist-with-updated-version
 	for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do					\
 	  image=`$(top_builddir)/pre-inst-env						\
 	    guix system vm-image $(GUIX_SYSTEM_VM_IMAGE_FLAGS)				\
+	    --save-provenance								\
 	    --system=$$system --fallback						\
 	    gnu/system/examples/vm-image.tmpl` ;					\
 	  if [ ! -f "$$image" ] ; then							\
diff --git a/doc/guix.texi b/doc/guix.texi
index f6522a994251c26df91bf70feace6bca58661dad..0fb81e441fb7ca79de5760bc45a65989996556b4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -27252,7 +27252,8 @@ This image boots the Xfce graphical environment and it contains some
 commonly-used tools.  You can install more software in the image by running
 @command{guix package} in a terminal (@pxref{Invoking guix package}).  You can
 also reconfigure the system based on its initial configuration file available
-as @file{/etc/config.scm} (@pxref{Using the Configuration System}).
+as @file{/run/current-system/configuration.scm} (@pxref{Using the
+Configuration System}).
 
 Instead of using this pre-built image, one can also build their own virtual
 machine image using @command{guix system vm-image} (@pxref{Invoking guix