From 9d9e64508186e5f9efbe45302134cd709b25e47b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Sun, 4 Nov 2012 21:44:42 +0100
Subject: [PATCH] distro: Go for one module per package.

The alternative, which was to use one module per category, would
probably not scale well.  First, because many packages could fall into
several categories (does GnuTLS go into "networking", "security", or
"libraries"?).  Second, because that could easily lead to circular
dependencies among modules ("security" and "networking" depend on each
other, etc.)

* distro/packages/databases.scm: Rename to...
* distro/packages/recutils.scm: ... this.
* distro/packages/typesetting.scm: Rename to...
* distro/packages/lout.scm: ... this.
* Makefile.am (MODULES): Adjust accordingly.
* po/POTFILES.in: Likewise.
---
 Makefile.am                                     |  4 ++--
 distro/packages/{typesetting.scm => lout.scm}   | 10 +---------
 distro/packages/{databases.scm => recutils.scm} | 10 +---------
 po/POTFILES.in                                  |  4 ++--
 4 files changed, 6 insertions(+), 22 deletions(-)
 rename distro/packages/{typesetting.scm => lout.scm} (97%)
 rename distro/packages/{databases.scm => recutils.scm} (92%)

diff --git a/Makefile.am b/Makefile.am
index 8403081cb7f..9b0240a95f6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -43,10 +43,10 @@ MODULES =					\
   guix.scm					\
   distro.scm					\
   distro/packages/base.scm			\
-  distro/packages/databases.scm			\
   distro/packages/guile.scm			\
   distro/packages/ld-wrapper.scm		\
-  distro/packages/typesetting.scm
+  distro/packages/lout.scm			\
+  distro/packages/recutils.scm
 
 GOBJECTS = $(MODULES:%.scm=%.go) guix/config.go
 
diff --git a/distro/packages/typesetting.scm b/distro/packages/lout.scm
similarity index 97%
rename from distro/packages/typesetting.scm
rename to distro/packages/lout.scm
index 25d8e6119e8..3045afa3abf 100644
--- a/distro/packages/typesetting.scm
+++ b/distro/packages/lout.scm
@@ -16,18 +16,12 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro packages typesetting)
+(define-module (distro packages lout)
   #:use-module (guix packages)
   #:use-module (guix http)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
-;;; Commentary:
-;;;
-;;; Typesetting-related packages.
-;;;
-;;; Code:
-
 (define-public lout
   ;; This one is a bit tricky, because it doesn't follow the GNU Build System
   ;; rules.  Instead, it has a makefile that has to be patched to set the
@@ -131,5 +125,3 @@ (define out
 beginning.")
     (license "GPLv3+")
     (home-page "http://savannah.nongnu.org/projects/lout/"))))
-
-;;; typesetting.scm ends here
diff --git a/distro/packages/databases.scm b/distro/packages/recutils.scm
similarity index 92%
rename from distro/packages/databases.scm
rename to distro/packages/recutils.scm
index c1dc9260a9a..6221ee07c9e 100644
--- a/distro/packages/databases.scm
+++ b/distro/packages/recutils.scm
@@ -16,19 +16,13 @@
 ;;; You should have received a copy of the GNU General Public License
 ;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-(define-module (distro packages databases)
+(define-module (distro packages recutils)
   #:use-module (distro)
   #:use-module (guix packages)
   #:use-module (guix http)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
-;;; Commentary:
-;;;
-;;; Database management software and related packages.
-;;;
-;;; Code:
-
 (define-public recutils
   (package
    (name "recutils")
@@ -56,5 +50,3 @@ (define-public recutils
 records, each record containing an arbitrary number of named fields.")
    (license "GPLv3+")
    (home-page "http://www.gnu.org/software/recutils/")))
-
-;;; databases.scm ends here
diff --git a/po/POTFILES.in b/po/POTFILES.in
index 887b7106eea..fcc84f32f02 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -1,9 +1,9 @@
 # List of source files which contain translatable strings.
 distro.scm
 distro/packages/base.scm
-distro/packages/databases.scm
 distro/packages/guile.scm
-distro/packages/typesetting.scm
+distro/packages/lout.scm
+distro/packages/recutils.scm
 guix/ui.scm
 guix-build.in
 guix-download.in
-- 
GitLab