From 9f51293cee7d00c9434e4a32c77034ad3d3887cc Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Fri, 24 Jul 2015 18:41:36 +0200
Subject: [PATCH] gnu: algebra: Prefix imported licenses.

* gnu/packages/algebra.scm (mpfrcx, fplll, pari-gp, gp2c, flint, arb,
  bc, fftw, eigen)[license]: Prefix imported licenses.
---
 gnu/packages/algebra.scm | 20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 01303c33b86..71e2ca6630d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -25,7 +25,7 @@ (define-module (gnu packages algebra)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages flex)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -58,7 +58,7 @@ (define-public mpfrcx
 implement the floating point approach to complex multiplication are
 implemented.  On the other hand, these comprise asymptotically fast
 multiplication routines such as Toom–Cook and the FFT.")
-   (license lgpl2.1+)
+   (license license:lgpl2.1+)
    (home-page "http://mpfrcx.multiprecision.org/")))
 
 (define-public fplll
@@ -79,7 +79,7 @@ (define-public fplll
    (description
     "fplll LLL-reduces euclidean lattices.  Since version 3, it can also
 solve the shortest vector problem.")
-   (license lgpl2.1+)
+   (license license:lgpl2.1+)
    (home-page "http://perso.ens-lyon.fr/damien.stehle/fplll/")))
 
 (define-public pari-gp
@@ -120,7 +120,7 @@ (define-public pari-gp
 polynomials, power series, algebraic numbers, etc., and a lot of
 transcendental functions.
 PARI is also available as a C library to allow for faster computations.")
-   (license gpl2+)
+   (license license:gpl2+)
    (home-page "http://pari.math.u-bordeaux.fr/")))
 
 (define-public gp2c
@@ -154,7 +154,7 @@ (define-public gp2c
 PARI is also available as a C library to allow for faster computations.
 
 GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
-   (license gpl2)
+   (license license:gpl2)
    (home-page "http://pari.math.u-bordeaux.fr/")))
 
 (define-public flint
@@ -205,7 +205,7 @@ (define-public flint
 GCDs, factoring, solving linear systems, and evaluating special
 functions.  In addition, FLINT provides various low-level routines for
 fast arithmetic.")
-   (license gpl2+)
+   (license license:gpl2+)
    (home-page "http://flintlib.org/")))
 
 (define-public arb
@@ -251,7 +251,7 @@ (define-public arb
 arithmetic.  It supports efficient high-precision computation with
 polynomials, power series, matrices and special functions over the
 real and complex numbers, with automatic, rigorous error control.")
-   (license gpl2+)
+   (license license:gpl2+)
    (home-page "http://fredrikj.net/arb/")))
 
 (define-public bc
@@ -292,7 +292,7 @@ (define-public bc
 an interactive environment for evaluating mathematical statements.  Its
 syntax is similar to that of C, so basic usage is familiar.  It also includes
 \"dc\", a reverse-polish calculator.")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public fftw
   (package
@@ -326,7 +326,7 @@ (define-public fftw
 transform (DFT) in one or more dimensions, of arbitrary input size, and of
 both real and complex data (as well as of even/odd data---i.e. the discrete
 cosine/ sine transforms or DCT/DST).")
-    (license gpl2+)))
+    (license license:gpl2+)))
 
 (define-public fftwf
   (package (inherit fftw)
@@ -405,4 +405,4 @@ (define-public eigen
 
     ;; Most of the code is MPLv2, with a few files under LGPLv2.1+ or BSD-3.
     ;; See 'COPYING.README' for details.
-    (license mpl2.0)))
+    (license license:mpl2.0)))
-- 
GitLab