From a080e50c153d3f72370e140eaf589d448867bf41 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Tue, 29 Mar 2016 14:30:38 +0200
Subject: [PATCH] gnu: Add r-withr.

* gnu/packages/statistics.scm (r-withr): New variable.
---
 gnu/packages/statistics.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 15c68238e22..28ac9673cc7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1260,6 +1260,25 @@ (define-public r-devtools
 tools to simplify the devolpment of R packages.")
     (license license:gpl2+)))
 
+(define-public r-withr
+  (package
+    (name "r-withr")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "withr" version))
+              (sha256
+               (base32
+                "0zbj3rd7dc0ycknmay7y7rm1qvnh9n05jw93gjggz46j2zfmy93y"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/jimhester/withr")
+    (synopsis "Run code with temporarily modified global state")
+    (description
+     "This package provides a set of functions to run R code in an environment
+in which global state has been temporarily modified.  Many of these functions
+were originally a part of the r-devtools package.")
+    (license license:gpl2+)))
+
 (define-public r-readr
   (package
     (name "r-readr")
-- 
GitLab