diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59670124361afccfa7204e68e23f61f9a95ab1e5..f89ab6b28146906dc2ace557e758edf9e8ec6719 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -430,8 +430,8 @@ (define* (make-linux-libre version hash supported-systems
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %linux-libre-version "5.1.12")
-(define %linux-libre-hash "0rzm3ixazqxfn767yayyf3ib889igg9nq7acf2wqcsmwbrrh5zcc")
+(define %linux-libre-version "5.1.14")
+(define %linux-libre-hash "1rpkkhzyks9bqk0j6djaacjxfb0jld4si4li1ws123ddf5krz8j2")
 
 (define %linux-libre-5.1-patches
   (list %boot-logo-patch