From a4eb83b709349ebbfe72ed473d0f65cdf5c4cbc7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Mon, 16 Nov 2015 15:51:43 +0100
Subject: [PATCH] gnu: eigen: Fix 'Cflags' value in 'eigen3.pc'.

* gnu/packages/algebra.scm (eigen)[source]: Augment snippet to address
  <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
---
 gnu/packages/algebra.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 07dfaafdc33..fb3b3e94b3d 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -399,7 +399,11 @@ (define-public eigen
                ;; anyway, so just skip them.
                '(substitute* "CMakeLists.txt"
                   (("add_subdirectory\\(unsupported\\)")
-                   "# Do not build the tests for unsupported features.\n")))))
+                   "# Do not build the tests for unsupported features.\n")
+                  ;; Work around
+                  ;; <http://eigen.tuxfamily.org/bz/show_bug.cgi?id=1114>.
+                  (("\"include/eigen3\"")
+                   "\"${CMAKE_INSTALL_PREFIX}/include/eigen3\"")))))
     (build-system cmake-build-system)
     (arguments
      '(;; Turn off debugging symbols to save space.
-- 
GitLab