From a512aa918168193249b8a277eab65e015d2dd9e3 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 8 Apr 2019 13:54:15 +0300
Subject: [PATCH] gnu: openshot: Use wrap-qt-program.

* gnu/packages/video.scm (openshot)[arguments]: Add more modules.
Adjust custom 'wrap-program phase to use wrap-qt-program.
---
 gnu/packages/video.scm | 15 +++++++++------
 1 file changed, 9 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cf11f0e01f3..8bf13c192e6 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3383,6 +3383,11 @@ (define-public openshot
        ("qtsvg" ,qtsvg)))
     (arguments
      `(#:tests? #f                      ;no tests
+       #:modules ((guix build python-build-system)
+                  (guix build qt-utils)
+                  (guix build utils))
+       #:imported-modules (,@%python-build-system-modules
+                            (guix build qt-utils))
        #:phases (modify-phases %standard-phases
                   (delete 'build)       ;install phase does all the work
                   (add-before 'install 'set-tmp-home
@@ -3392,12 +3397,10 @@ (define-public openshot
                       (setenv "HOME" "/tmp")
                       #t))
                   (add-after 'install 'wrap-program
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (wrap-program (string-append (assoc-ref outputs "out")
-                                                   "/bin/openshot-qt")
-                        `("QT_PLUGIN_PATH" prefix
-                          ,(list (string-append (assoc-ref inputs "qtsvg")
-                                                "/lib/qt5/plugins/")))))))))
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let ((out (assoc-ref outputs "out")))
+                        (wrap-qt-program out "openshot-qt"))
+                      #t)))))
     (home-page "https://openshot.org")
     (synopsis "Video editor")
     (description "OpenShot takes your videos, photos, and music files and
-- 
GitLab