diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0936a5b379ef25d87c301b445194046d7bfe6323..4286b7bef6700f479dcc3222ef1b9d161869786b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -214,7 +214,7 @@ (define deblob-scripts-5.8
 
 (define deblob-scripts-5.4
   (linux-libre-deblob-scripts
-   "5.4.61"
+   "5.4.62"
    (base32 "0ckxn7k5zgcqk30dq943bnamr6a6zjbw2aqjl3x30f4kvh5f6k25")
    (base32 "1b3q88i2qfdxyvpi9f7jds0qlb8hfpw87mgia096ax6822c2cmyb")))
 
@@ -391,10 +391,10 @@ (define-public linux-libre-5.8-pristine-source
                             (%upstream-linux-source version hash)
                             deblob-scripts-5.8)))
 
-(define-public linux-libre-5.4-version "5.4.61")
+(define-public linux-libre-5.4-version "5.4.62")
 (define-public linux-libre-5.4-pristine-source
   (let ((version linux-libre-5.4-version)
-        (hash (base32 "197y2yb60m1k8i7mig4pa9wsrklfxq81ba3zfahwb2b31w2kvwc6")))
+        (hash (base32 "0w49y8lymz23x4mr5byaxnrkhm56lwfhnqkra07hqyfr5y63v216")))
    (make-linux-libre-source version
                             (%upstream-linux-source version hash)
                             deblob-scripts-5.4)))