From a560641a604c4766acfa2ff015a10c9465a721eb Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 25 May 2018 12:11:41 +0200
Subject: [PATCH] gnu: openmpi: Reintroduce PSM (Intel TrueScale) support.

Fixes a regression introduced in
9129804230a3a4272731609f6418b876ba450575 whereby PSM would never be
added as an input.

* gnu/packages/mpi.scm (openmpi)[inputs]: Re-add PSM on supported
systems.
---
 gnu/packages/mpi.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5496ea9c9e6..e8d28d6060c 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -168,10 +168,10 @@ (define-public openmpi
      `(("hwloc" ,hwloc "lib")
        ("gfortran" ,gfortran)
        ("libfabric" ,libfabric)
-       ,@(match (%current-system)
-                ((member (package-supported-systems psm))
-                 `(("psm" ,psm)))
-                (_ `()))
+       ,@(if (and (not (%current-target-system))
+                  (member (%current-system) (package-supported-systems psm)))
+             `(("psm" ,psm))
+             '())
        ("rdma-core" ,rdma-core)
        ("valgrind" ,valgrind)))
     (native-inputs
-- 
GitLab