From a59e017cb14ac4b30b46fbd7f2a76b29004d25f4 Mon Sep 17 00:00:00 2001
From: Cyril Roelandt <tipecaml@gmail.com>
Date: Sat, 27 Jun 2015 00:30:07 +0200
Subject: [PATCH] gnu: Add python-mccabe.

* gnu/packages/python.scm (python-mccabe, python2-mccabe): New variables.
---
 gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cf9d3cad540..fd3fedec271 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3953,3 +3953,30 @@ (define-public python-pyflakes
     (description
       "Pyflakes statically checks Python source code for common errors.")
     (license license:expat)))
+
+(define-public python-mccabe
+  (package
+    (name "python-mccabe")
+    (version "0.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/m/mccabe/mccabe-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "05ix3vdv5hjk4irl97n2n3c4g1vqvz7dbmkzs13f3bx97bxsczjz"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/flintwork/mccabe")
+    (synopsis "McCabe checker, plugin for flake8")
+    (description
+      "This package provides a Flake8 plug-in to compute the McCabe cyclomatic
+complexity of Python source code.")
+    (license expat)))
+
+(define-public python2-mccabe
+  (package-with-python2 python-mccabe))
-- 
GitLab