diff --git a/gnu-system.am b/gnu-system.am
index 96731240839d0e1d5c853cb724c5a068f7767a4f..ce134af0718399a639786320c290872ada0576bf 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -470,6 +470,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/xf86-video-nv-remove-mibstore.patch	\
   gnu/packages/patches/xf86-video-openchrome-glibc-2.20.patch	\
   gnu/packages/patches/xf86-video-r128-glibc-2.20.patch		\
+  gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch \
   gnu/packages/patches/xfce4-panel-plugins.patch		\
   gnu/packages/patches/xmodmap-asprintf.patch
 
diff --git a/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch b/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch
new file mode 100644
index 0000000000000000000000000000000000000000..5fd91006093a0f76a66df673883b7c0cf371c8ec
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-siliconmotion-remove-mibstore.patch
@@ -0,0 +1,16 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server.  Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-siliconmotion-1.7.7/src/smi_driver.c.~1~	2012-07-17 00:53:21.000000000 -0400
++++ xf86-video-siliconmotion-1.7.7/src/smi_driver.c	2014-12-19 01:30:16.708884086 -0500
+@@ -1750,8 +1750,6 @@
+ 		   "Done writing mode.  Register dump:\n");
+     SMI_PrintRegs(pScrn);
+ 
+-    miInitializeBackingStore(pScreen);
+-
+ #ifdef HAVE_XMODES
+     xf86DiDGAInit(pScreen, (unsigned long)(pSmi->FBBase + pScrn->fbOffset));
+ #endif
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 230d41fc994b436b3b7701e616e67e50dd406fba..5470000a9937e3fc509ecac19a83da4e690cd44b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2848,17 +2848,20 @@ (define-public xf86-video-savage
 (define-public xf86-video-siliconmotion
   (package
     (name "xf86-video-siliconmotion")
-    (version "1.7.6")
+    (version "1.7.7")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/xf86-video-siliconmotion-"
+               "mirror://xorg/individual/driver/xf86-video-siliconmotion-"
                version
                ".tar.bz2"))
         (sha256
           (base32
-            "01sdl6ky1vmvmfgx2d44i35rqafi0z07xdy40cvindcr2k91p7x5"))))
+           "1an321kqvsxq0z35acwl99lc8hpdkayw0q180744ypcl8ffvbf47"))
+        (patches
+         (list
+          (search-patch "xf86-video-siliconmotion-remove-mibstore.patch")))))
     (build-system gnu-build-system)
     (inputs `(("xorg-server" ,xorg-server)))
     (native-inputs `(("pkg-config" ,pkg-config)))