diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b206fb32f550a07bca15ecbee8e2e91c2115a525..406a2ad5a135639ba9f5fc8d23f70fdc986b148e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1534,6 +1534,14 @@ (define-public mpv
                 (("\"youtube-dl\",")
                  (string-append "\"" ytdl "/bin/youtube-dl\",")))
               #t)))
+         (add-before 'configure 'build-reproducibly
+           (lambda _
+             ;; Somewhere in the build system library dependencies are enumerated
+             ;; and passed as linker flags, but the order in which they are added
+             ;; varies.  See <https://github.com/mpv-player/mpv/issues/7855>.
+             ;; Set PYTHONHASHSEED as a workaround for deterministic results.
+             (setenv "PYTHONHASHSEED" "1")
+             #t))
          (add-before
           'configure 'setup-waf
           (lambda* (#:key inputs #:allow-other-keys)