diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fd142a5c0a60c1ec0a63fa2043359c1de157b86b..5412f4451de81f953269497e1e475b929eb32148 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2499,6 +2499,10 @@ (define-public xf86-video-geode
     (build-system gnu-build-system)
     (inputs `(("pkg-config" ,pkg-config)
               ("xorg-server" ,xorg-server)))
+    (supported-systems
+     ;; This driver is only supported on i686 systems.
+     (filter (lambda (system) (string-prefix? "i686-" system))
+             %supported-systems))
     (home-page "http://www.x.org/wiki/")
     (synopsis "Xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")